Message
Invoice could not be completed in Moneybird. Cause: An invalid email address was specified.
Cause
The source data we are trying to sync with the link contains an invalid email address. Moneybird checks the email address and displays an error message if an invalid email address is entered.
Solution
Change the customer's email address from this invoice, receipt or order in the source package to a valid email address and try again. Learn how to resync a failed item here.