All Collections
Error messages
Moneybird error: Technical details: HTTP code: 422 Payload: Body: {"error":{"customer_id":["is already in use"]}}
Moneybird error: Technical details: HTTP code: 422 Payload: Body: {"error":{"customer_id":["is already in use"]}}

Technical details: HTTP code: 422 Error: {"error":{"customer_id":["is already in use"]}}

Updated over a week ago

Message

Error: {"error":{"customer_id":["is already in use"]}}

Cause

The numeric customer ID in Moneybird does not match the actual highest ID. This causes the integration to try to create a contact with an ID that is already in use.

Solution

This issue cannot be resolved by Combidesk.

First, try step 1. If that doesn't work, then move on to step 2.

  1. Manually create a contact in Moneybird with the highest customer number so far - if you then add a contact through the integration, it will automatically be assigned the next number. The problem should be resolved.

  2. Contact Moneybird through the help section of your Moneybird account or at support@moneybird.com and use your Combidesk error message as a starting point. Use the email template below. After Moneybird has adjusted the ID, the integration will pick it up and process it further.

Example Email

Subject: Moneybird error message: Error: {"error":{"customer_id":["is already in use"]}}

Text:

My Moneybird email address:

My Moneybird administration name:

Dear Moneybird support,

The Combidesk integration is attempting to create a new contact in my Moneybird account using the contacts API, but we are getting the error message "*customer_id":["is already in use"]* even though the integration does not specify a *customer_id*.

You investigated this issue in the past and found the cause - the numeric customer ID you retrieved did not match the actual highest ID. This caused you to try to create a contact with an ID that was already in use. You manually corrected this at that time.

Could you please do the same for this current situation? Below is the error message from the Combidesk integration:

Invoice [Number: ****] could not be completed in Moneybird. Cause: Technical details: HTTP code: 422 Payload: {"contact":{"firstname":"John","lastname":"Doe","address1":"Acrmestreet","address2":"100","zipcode":"1234","city":"Amsterdam","country":"NL","email":"john.doe@acme.com"}} Error: {"error":{"customer_id":["is already in use"]}}

Best regards,

Did this answer your question?