Alle collecties
Foutmeldingen
Moneybird
Moneybird foutmelding: Technical details: HTTP code: 422 Payload: Body: {"error":{"customer_id":["is already in use"]}}
Moneybird foutmelding: Technical details: HTTP code: 422 Payload: Body: {"error":{"customer_id":["is already in use"]}}

Technical details: HTTP code: 422 Error: {"error":{"customer_id":["is already in use"]}}

Meer dan een week geleden bijgewerkt

Melding

Body: {"error":{"customer_id":["is already in use"]}}

Oorzaak

Het numeric klanten id in Moneybird komt niet overeen met het daadwerkelijke hoogste id. Hierdoor probeert de koppeling een contact aan te maken op een ID die al in gebruik is.

Technical details: HTTP code: 422 Payload: {"contact":{"firstname":"John","lastname":"Doe","address1":"Acrmestreet","address2":"100","zipcode":"1234","city":"Amsterdam","country":"NL","email":"john.doe@acme.com"}} Error: {"error":{"customer_id":["is already in use"]}}

Oplossing

Dit kan niet door Combidesk worden opgelost.

Probeer eerst stap 1. Lukt dat niet, ga dan over naar stap 2.

  1. Maak in Moneybird handmatig een contact aan met het hoogste klantnummer tot nu toe - als je daarna via de koppeling een contact laat toevoegen, dan wordt daar automatisch het eerstvolgende nummer aan gekoppeld. Het probleem zou moeten zijn verholpen.

  2. Neem even via de help in je Moneybird account of support@moneybird.com contact op en gebruik je Combidesk foutmelding als uitgangspunt. Gebruik de e-mailtemplate hieronder.
    Nadat Moneybird de ID heeft aangepast, zal de koppeling deze verder oppakken en verwerken.


Voorbeeldmail

Onderwerp: Moneybird foutmelding: Body: {"error":{"customer_id":["is already in use"]}}

Tekst:

Mijn Moneybird e-mailadres:

Mijn Moneybird administratienaam:

Beste Moneybird support,

De koppeling van Combidesk probeert middels de contacts API een nieuwe contact aan te maken in mijn Moneybird account, maar we krijgen de melding *"customer_id":["is

already in use"]* terwijl de koppeling geen *customer_id* specificeert.

Jullie hebben dit in het verleden onderzocht en toen de oorzaak gevonden -> Het numeric klanten id die jullie ophaalden, kwam niet overeen met het daadwerkelijke hoogste id. Hierdoor probeerden jullie een contact aan te maken op een ID die al in gebruik was. Jullie hebben dit toen handmatig correct gezet.

Zouden jullie dit voor deze huidige situatie ook willen doen? Hieronder de foutmelding uit de Combidesk koppeling:

Factuur [Nummer: ****] kon niet worden voltooid in Moneybird. Oorzaak: Technical details: HTTP code: 422 Payload: {"contact":{"firstname":"John","lastname":"Doe","address1":"Acrmestreet","address2":"100","zipcode":"1234","city":"Amsterdam","country":"NL","email":"john.doe@acme.com"}} Body: {"error":{"customer_id":["is already in use"]}}

Met vriendelijke groet,

Was dit een antwoord op uw vraag?